ospf part7: OSPF areas, router types, ospf routes & LSA types

Hi mate, I’m back once again. This time will dig deeper on OSPF.  We will discuss some of important concepts on OSPF which will be useful as we transition on CCNP-Route

 

OSPF Areas

  • Why do we implement areas on ospf network and what will be the use of that?
  • –> Here’s how it goes, when there is a network changes  let us say a new network  address was added on ospf topology with 50 routers, let us go back on ospf process, the local router will create its own LSA, will send hello to multicast address 224.0.0.5 or all ospf speaking routers and will expect for a hello message which has its own router-id and so on and so forth that it reaches the stage of asking for LSU. That seems to be not a complicated process however our goal in routing is that all routers can reach or ping each others even though there are 50 routers in the network. This scenario is feasible but this will lead to excessive CPU utilization and slower convergence. Why? because if there are 50 routers connected on that ospf network, it may require time for router LSAs to be propagated from routers near the originating router to router remote to the originating router.

 

Solution for that is implementing OSPF areas. How does it work and how does it help?

First let us define OSPF areas as a logical grouping of OSPF areas. Let us remember that the LSA that routers send on our discussion awhile ago is just router LSA. Router LSA is only sent on to ospf speaking routers within the same area. When we activate an ospf network, say for example when we type:

en
conf t
router ospf 100
network 10.0.10.0 0.0.0.255 area 0

There are three effects that will happen to the network:

1.) Activates all the interfaces that can be covered on the network statement- if we got interfaces  with ip addresses 10.0.0.1 , 10.0.0.2 and 10.0.0.9, all of those interfaces will be activated since they are covered in the network statement

2.) Advertises the network address of the activated interface

3.) Puts the activated interface on the area specified.

Since our goal is to avoid slow convergence and  high CPU utilization, router LSA is sent only on the area where the local router belongs. So the question that I guess that runs on your mind is how will the information or LSA be sent to routers on different areas if the router LSA is sent only to  the area where the local router belongs. The solution is that another LSA is created and advertised but we will go further to that but let me discuss first an important concept before we proceed to that.

OSPF Area types

1.) Regular area- any areas that is not area 0

2.) Backbone Area – area 0

Just take the definition as it is so that you will understand some other OSPF terminologies which we will discuss later.

OSPF router types

1.) Internal routers- routers that belong only to single area

2.) Area Border Routers (ABR) – routers that connect regular area to backbone area. The name itself defines that it is the border between regular and backbone area.

3) Backbone Router – routers with at least one interface which is connected to backbone area or area 0

4.) External routers – these are routers that are connected to internet, non-ospf router and other ospf AS system. Other OSPF AS system means that it runs OSPF as well but on the other company. Let us say it runs OSPF on AT&Tand the external router runs OSPF on Sprint.

 

19A1.png

 

Alright, let us try to identify the terminologies that we discussed before and let us identify those on the image above.

OSPF area types:

a.)Regular Area- area 15 and area 25; defined as area 0

b.) Backbone Area – of course no other than but area 0

 

OSPF router types:

a.)Internal routers-  defined as router with single area; those are R1, R3,R5,R6, R8 and R9 on the picture above

2.) Area Border router – defined as router that connects backbone area and regular area, those are  R2 and R7 on the picture above

3.) Backbone Router – define as router with at least one interface connected to area 0

So on the picture above, those are routers R2,R4, R5, R6, and R7

4.) External routers – let us say that R6 is connected to a router that only runs EIGRP, it will be removed on the list of internal routers but considered as external routers.

Be reminded that a router can be ABR and backbone router at the same time. Or a certain router on an OSPF network can have two classification of ospf router types.

Three types of OSPF routes:

1.) Inter- Area Routes-  routes within the different area; denoted by ‘O IA” on the routing table

2.) Intra-Area routes- route within the same area; denoted by ‘O” on the routing table

3.) External Routes – routes from outside ospf domain;denoted by ‘O E1 or OE2″ on the routing table

 

Alright! So I am now able to define those OSPF terminologies and hopefully you understood it by example. So we will be dealing back with the question awhile ago: if router LSA is only sent to routers on the same area then how will the LSA created by the originating router be advertised to routers on different area? The solution is

SUMMARY LSA

The scenario goes like this

1.) A network was added on R3 so it will update its LSA and will send hello to R1.

2.) R1 will save  R3’s LSA and will send hello back to R1 up until R1 and R3 is fully adjacent.

3.) R1 will advertise R3’s router LSA to R2

4.) R2 will save R3’ s router LSA advertised by R1 and will follow OSPF process up until R2, R1 and R3 are fully adjacent. Now, since R2 is the ABR, its task is to create summary LSA to advertise the router from area 15 to area 0. Be reminded that summary LSA is only create by ABR.

So if we will define SUMMARY LSA – it is the LSA created by ABR to advertise router LSA of a router on different area to another area.19A2

 

The thing here is that on R4’s perspective, he only got one LSA from R1, R3 and R2 . Meaning to say the router LSAs which must be advertised by R1, R2 and R3  are viewed by R2 as just one LSA or summarized as SUMMARY LSA. So on R4’s perspective after full adjacency on all routers, R4 only got 4 neighbors instead of 9 routers.

We will continue the scenario and definitely I don’t have to elaborate other steps since it will be repetitive. The steps and scenario will be on the picture.

19A3.png

Alright! We already achieved Full adjacency on all routers, hopefully you understood the ospf terminologies, ospf areas, router types, ospf routes and the new LSA that we got.

Talk to you soon mate!

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ospf part 4: ospf authentication

Hi there mate! This will be the last discussion on OSPF configuration. The rest of the OSPF topics will discuss how OSPF works and the content of Hello packet. The last topic that we had was configuring passive interfaces for security reasons. This time, we will configure OSPF with authentication using encrypted passwords. The need for configuring authentication is very simple, it is to provide security to active interfaces.  I mean active interface are those interfaces that receives and sends hello or OSPF updates. They cannot be a passive interface so authentication will be the best process to secure those interfaces.

Just come to imagine the scenario below wherein12a1

Instead that the interface serial 1/0 of router 1 is connected to router2. It was connected to hacking router so it will lead to security breach.

So let us get back to our original topology.

12a2.PNG

Authentication SYNTAX:

en 
conf t
router ospf {process#} <— process # 
area {area#} authentication message digest < — we set authentication on the entire area on specific router
exit
int serial x/x
ip ospf message-digest-key 1 md5 {password} <— the authentication used is MD5 , you can further check on google how it works 

Note: 1.) We set password on each interface since the security breach may happen on each                     interface

2.) We can set multiple passwords on each interface: the syntax will follow:

 

int serial x/x
ip ospf message-digest-key 1 md5 {password}
ip ospf message-digest-key 2 md5 {password}

Very easy configuration right? So let us try to check the configuration on each router.
en
conf t
router ospf 100
area 0 authentication message-digest
exit
int se 1/0
ip ospf message-digest-key 1 md5 cisco

12a3

As we can see, opsf neighbor adjacency went down. It is for the reason that the neighbor router is not also configured with authentication and so they will not established neighbor relationship. Another way to verify: show ip ospf neighbor

12a4

So no neighbor relationship established. We can now continue with R2 authentication configuration:

@r2

en
conf t
router ospf 100
area 0 authentication message-digest
exit

12a5

As I go on, I can see that neighbor adjacency went down even without configuring the interfaces. It is for the reason that authentication was configured globally so it affects all the interfaces involved. We need to go by interfaces so that it would be more secured and to specify the password. How we will enter a locked door without a key? There should be a key. We need to specify the password / key-string. Below shows that no neighbor adjacency was established.

12a6

Let us continue the configuration:

int se 1/0
ip ospf message-digest-key 1 md5 cisco
int se 1/1
ip ospf message-digest-key 1 md5 cisco
exit

Below is what happened when I configured authentication on R2. We can see that serial 1/0 went up since it is connected to R1 and R1 has already md5 configuration. We can see on neighbor table that only R1 exists since R3 doesnt have md5 configuration.

12a7.png

Below is the neighbor table of R1, it shows that he can now see R2

12a8

Lastly, let us configure R3:
en
conf t
router ospf 100
area 0 authentication message-digest
exit
int se 1/1
ip ospf message-digest-key 1 md5 cisco
exit

12a9.png

Nothing much special with R3 configuration. We already discussed that serial 1/1 is possible to turn up since all routers has already md5 authentication and also router 2 appears on neighbor table. One thing that I can add to is that you alway see that term “from loading to FULL”. Those are stages of neighbor adjacency which we will discuss on the next topics.

I guess right now, you wonder how ospf works? We will discuss that on the next topic.

OSPF part 2: Router-ID

Hi mate, good morning!  We will be dealing back with our network topology that we configured before.o7a

You wonder what is router-id right? Router-id is the identifier of router on the perception of another router. I am sorry if it is a little bit confusing. Here’s how it goes, R1 would identify R2 by R2’s router-id and R2 would identify R1 by R1’s router ID.

I hope that your GNS3 is now ready. Kindly input ” show ip protocols”

12a.PNG

Router-ID is an important concept in each routing protocols specially with OSPF and EIGRP. When R1 would like to connect to R2, of course R1 should introduce himself and R1 will introduce his router-id as his name. On the figure above, you would see ROUTING INFORMATION SOURCES and the ip address written on the gateway column is the router-id. So how would we know the router-id which should be listed? There are hierarchy to know the router-id and these are the following from the top priority to the least priority.

1.) Hard-coded router-id – this is the router-id that we manually configure.

2.) Highest loopback address- very self-explanatory, the loopback address which has highest numerical value

3.)Highest ip address-   very self-explanatory, the ip address which has highest numerical value

If ever you wonder why there are two router-ids on the “show ip protocols” command, it was because there are two neighbor routers.

12b

Before we proceed with manually configuring the IP address, let us try to remove the loopback addresses, to know if removing the loopback address would lead us that the highest IP address will be the last resort if there are no loopback address and no hard-coded router-id. Since it is very obvious on the figure above that highest loopback address was used instead of hard coded router-id and highest IP address.

Let us try to implement:

on R2

conf t

int lo 0
ip address 192.168.91.1 255.255.255.0
shut
int lo 1
ip address 192.168.92.1 255.255.255.0
shut
int lo 2
ip address 192.168.93.1 255.255.255.0
shut
exit
do sh ip int br

 

on R3

en
conf t

int lo 0
ip address 10.0.0.1 255.255.255.0
shut
int lo 1
ip address 20.0.0.1 255.255.255.0
shut
exit
do sh ip int br

 

As you observed, the router-ids are not changed. Why is it happening? because R1 already knows R2 as 192.168.93.1 and R1 already knows R3 as 20.0.0.1 and so in the event there are changes with R2 and R3, R1 would still identify R2 and R3 as their original router-ids unless R2 and R3 reintroduce themselves to R1.  In order that R2 and R3 will reintroduce themselves to R1, we need to restart the routers.

12c

 

Alright, the routers just got restarted, and let us check sh ip protocols command,

12d

You would see that 201.52.30.2 which is not a loopback nor hard-coded router-id on the routing information sources. Due to incorrect configuration, only one router-is is known by R1 and  R3’s router-id is not known by R1. Also, you will see above the the router-id of R1 still remain as 172.16.17.1 since we did not touch that.So let us retrieve the loopback addresses.

12e.PNG

***********************************************************************Configuration of Router-IDs

Mate, it is very clear that the reason why we consider hard-coded router-ids as top of the hierarchy is because it is something stable or meaning to say it will not vary. What I mean is that in the event that the interface with highest ip address went down or the loopback address was accidentally went to administratively down, it may cause misconfiguration which will lead to network disruption.So it is advisable in the industry, to configure router-id. So let us take note that router-id doesnt necessarily mean that it is an ip address though it looks like ip address.

Let us designate the router-ids of routers:

R1 1.1.1.1

R2 2.2.2.2

R3 3.3.3.3

SYNTAX:

en
conf t
router ospf  {process#}
router-id x.x.x.x
do clear ip ospf process  —> it will appear and it is your discretion whether to restart router or clear the router-ids, then type  YES
do wr
exit
do sh ip protocols

@R1

en
conf t
router ospf 100
router-id 1.1.1.1
do clear ip ospf process  ; type YES
do wr
exit
do sh ip protocols

 

@r2

en
conf t
router ospf 100
router-id 2.2.2.2
do clear ip ospf process; type YES
do wr
exit

 

@R3

en
conf t
router ospf 100
router-id 3.3.3.3
do clear ip ospf process; type YES
do wr
exit

 

And there you go, we will check the router-id of R1, please take note that old router-ids may take time to be removed on the sh ip protocols table

12f

Let’s check R2

12g

 

Let’s check R3

12h

And there dyou go! We are able to at least configure router id on OSPF protocol. Next ospf process that we will configure is passive inteface and security features of OSPF. After that, we will explain how OSPF works. Stay tuned!

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.9 OSPF (Open Shortest Path First Version 2) Part 1: Configuration and Router-ID

Happy New year Mate! We are moving on my most favorite routing protocol—- OSPF. I can still remember during the technical interview, I was asked what is my most favorite routing protocol and why? Since the only routing protocol which was fresh in my mind during that time is OSPF, I answered OSPF because blah blah blah. A follow-up question came along—> how OSPF works? To make the long story short, OSPF saved my ass. And that is my story about my most favorite routing protocol.

Too much for introduction, below will be the trivial information that you need to know about OSPF.

1.) link-state protocol( we will discuss this later)

2.) Administrative distance of 110- just a recap administrative distance is the reference of the router which protocol router should follow in the event that there are multiple protocols running on it.

3.) Metric–> cost, in the event that there are multiple paths going to a specific host, cost  of the ospf operated router will serve as the reference of the router. The lower the cost, the more the router will follow that path.

4.)Dynamic routing protocol- all of the other routing protocols that we will be discussing are dynamic routing protocol. Dynamic routing protocols are protocols that will adapt for  any network changes. Lets’s say link 1 fails, you don’t have to manually reconfigure the device just to troubleshoot the network failure.

***********************************************************************

SYNTAX AND CONFIGURATION:

You wonder why we proceed already with the configuration without knowing the concept or how ospf works? –> because it will be better if we will see the terminologies involved and how it will affect the network.Also, we will just do the basic configuration, addendum will follow to explain their functions.

–> I preferred to it this way for easy explanation and to avoid redundancy.

SYNTAX:

en
conf t
router ospf {Process #}
network { directly connected network address} {wildcard mask}(mandatory) {area#}
exit

Lemme explain the syntax first

1.) Process # – it wont hurt much the network whether devices have different routing process, it’s just part of the syntax.

2.) Directly connected network address – when you do ” show ip route” on a specific router, we will include all network address listed.

3.) Wildcard mask- It is exact opposite of subnet mask. It gives the same concept to be more specific of the network. The reason why there are two concepts like subnet mask and wildcard mask though they function almost the same is because using wildcard mask will gives faster decoding because of logical functions used e.g. NAND, AND.

4.) Area #–> we will deal further with area # but one thing to remember is that interfaces that face each other should have the same area#

Network topology below( same topology as static configuration):

0101a.PNG

initial configuration:

@ BPO_MAIN_BLDG_1

enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_MAIN_BLDG_1
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr

@BPO_MAIN_BLDG_2

enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_MAIN_BLDG_2
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
@BPO_MAIN

enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_MAIN
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr

@BPO_BRANCH
enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_BRANCH
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
@BPO_BRANCH_ANNEX_1
enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_BRANCH_ANNEX_1
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
@BPO_BRANCH_ANNEX-2
enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_BRANCH_ANNEX-2
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
***************************
@ main bldg 1

en
conf t
int se 3/0
ip add 200.0.0.1 255.255.255.252
no shut
exit
int se 2/0
ip address 200.0.0.17 255.255.255.252
no shut
exit

@main bldg 2
en
conf t
int se 2/0
ip add 200.0.0.18 255.255.255.252
shut
no shut
exit
int se 3/0
ip add 200.0.0.5 255.255.255.252
shut
no shut
exit

@ BPO_MAIN

en
conf t
int se 6/0
ip add 200.0.0.2 255.255.255.252
no shut
exit
int se 7/0
ip add 200.0.0.6 255.255.255.252
no shut
exit
int se 2/0
ip add 200.0.0.25 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.29 255.255.255.252
no shut
exit
int fa 0/0
no shut
exit

@ BPO_BRANCH

en
conf t
int se 2/0
ip add 200.0.0.26 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.30 255.255.255.252
no shut
exit
int se 6/0
ip add 200.0.0.9 255.255.255.252
no shut
exit
int se 7/0
ip add 200.0.0.13 255.255.255.252
no shut
exit
int fa 0/0
no shut
exit
@bpo annex 1

en
conf t
int se 2/0
ip add 200.0.0.10 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.21 255.255.255.252
no shut
exit
int gigabitEthernet7/0
no shut
exit

@bpo annex 2

en
conf t
int se 2/0
ip add 200.0.0.14 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.22 255.255.255.252
no shut
exit
int gigabitEthernet 8/0
no shut
exit

Additional configuration:

we will configure the speed of the link

First let us check  the link of serial 6/0 of router 3, it is part of link 1 which must have 4096 kbps of speed.

0101b.PNG

R1 is already configured with the ff syntax:

conf t
int se 3/0
bandwidth 4096
exit
conf t
int se 2/0
bandwidth 3072
exit

0101c

R3 configuration:

conf t
int se 6/0
bandwidth 4096
exit
int se 7/0
bandwidth 2048
exit
int se 2/0
bandwidth 4096
exit
int se 3/0
bandwidth 6144
exit

0101d.PNG

There you go, we achieved the 4096 link speed requirement.

the continuation of  config:

@R1
conf t
int se 3/0
bandwidth 4096
exit
conf t
int se 2/0
bandwidth 3072
exit

@R2
conf t
int se 2/0
bandwidth 3072
exit
int se 3/0
bandwidth 2048
exit

@ R3
conf t
int se 6/0
bandwidth 4096
exit
int se 7/0
bandwidth 2048
exit
int se 2/0
bandwidth 4096
exit
int se 3/0
bandwidth 6144
exit

@ R4
conf t
int se 2/0
bandwidth 4096
exit
int se 3/0
bandwidth 6144
exit
int se 6/0
bandwidth 1024
exit
int se 7/0
bandwidth 4096
exit

@ R5
conf t
int se 2/0
bandwidth 1024
exit
int se 3/0
bandwidth 3072
exit

@R6
conf t
int se 2/0
bandwidth 4096
exit
int se 3/0
bandwidth 3072
exit

 

*************************OSPF CONFIG***********************************

set process# as 100

area as area 0

 

0101e.PNG

verify:

0101f.PNGNo OSPF yet on routing table because neighbor relationship is not yet established on other routers

0101g.PNG

0101h

Aha! no ospf was establishe but, there is a highlighted notification sent

let’s try to verify once again after that notification appeared

0101i

There you go, OSPF was established, and we will analyze the highlighted network, we observed that the cost is 110 , which is the default cost, and the metric is 56. Also it was learned by the router by the help of 200.0.0.17

0101j.PNG

0101k.PNG

0101l.PNG

0101m.PNG

Actually, it takes me more than 6 seconds to see this routing table.

Also,let us check R3 once again:

0101n.PNG

0101o.PNG

0101p.PNG

Let’try the last router

0101p.PNG

0101q.PNG

Let us try to check once again the routing table of R1

0101r.PNG

************OSPF CONFIGURATION*********************
@R1
conf t
router ospf 100
network 200.0.0.0 0.0.0.3 area 0
network 200.0.0.16 0.0.0.3 area 0
exit

do sh ip route

@R2
conf t
router ospf 100
network 200.0.0.4 0.0.0.3 area 0
network 200.0.0.16 0.0.0.3 area 0
exit
do sh ip route

@R3

conf t
router ospf 100
network 200.0.0.0 0.0.0.3 area 0
network 200.0.0.4 0.0.0.3 area 0
network 200.0.0.24 0.0.0.3 area 0
network 200.0.0.28 0.0.0.3 area 0
exit
do sh ip route

@R4

conf t
router ospf 100
network 200.0.0.8 0.0.0.3 area 0
network 200.0.0.12 0.0.0.3 area 0
network 200.0.0.24 0.0.0.3 area 0
network 200.0.0.28 0.0.0.3 area 0
exit
do sh ip route

@ R5
conf t
router ospf 100
network 200.0.0.8 0.0.0.3 area 0
network 200.0.0.20 0.0.0.3 area 0
exit
do sh ip route

@R6
conf t
router ospf 100
network 200.0.0.12 0.0.0.3 area 0
network 200.0.0.20 0.0.0.3 area 0
exit
do sh ip route

let’s try ping from

R1 to R6

R5 to R2

0101s.PNG

0101t.PNG

And there you go, we got successful ping from right side to left side and vice versa. I haven’t include the inital ping image awhile ago to show the differences. Logically, this is just the configuration of OSPF. And now, we will check one important concept in OSPF—> router-id.

Verify:

sh ip protocols

0101u.PNG

Routing information sources listed and highlighted above are the router-id that I am telling you.

Did we configure those highlighted IP address above during the ospf configuration?

no!

How did router chose those IP address?

We will check it on the next part of the OSPF series.

************************END OF BLOG************************************

3.4 Configure, verify, and troubleshoot inter-VLAN routing

Finally got motivation to deal with inter-vlan routing. I just spoke with my idol, he is a network engineer in a known BPO company and he is one of those network engineers whom I don’t know personally but I admired him most. And yeah after almost 4 days of procrastination and being easily preoccupied, I am here trying to be the master of intervlan.

 

Need for inter-vlan routing:

The main purpose of VLAN is departmentalization or microsegmentation which means that a certain broadcast domain will be divided to VLAN broadcast domains. However, let us say that VLAN 10 would like to speak with VLAN 20, is there a possibility for VLANs to be connected? Yes, but we need the help of the router.

Be reminded that:

Devices within the same VLAN will only need a router to communicate with each other/ one another.

 

In the event that you would like devices from other vlan speak with one another, we will need the help of the router.

aaaaaa.PNG

If you want to do the network topology, the ip addresses are assigned above, the primary configurations are below:

GEN CONFIG

enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname SW3–> needs to be changed on each devices
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr

************************
@ SW1
vlan 10
name SALES
exit
vlan 20
name ACCOUNTING
exit
vlan 30
name IT
exit
vlan 40
name MARKETING
exit
******************************
@R1

conf t
int se 2/0
ip address 50.0.0.1 255.255.255.0
no shut
exit
int fa 0/0
ip address 192.168.1.1 255.255.255.0
no shut
exit
*******************************
@R2
conf t
int se 2/0
ip address 50.0.0.2 255.255.255.0
no shut
exit
int fa 0/0
ip address 172.16.50.1 255.255.255.0
no shut
exit
**********************************
conf t
vtp version 2
vtp domain cisco
vtp password class
vtp mode server

conf t
vtp version 2
vtp domain cisco
vtp password class
vtp mode server
*****************************
@ SW1
int range fa 0/1-2
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 1,10,20,30,40,50
exit
conf t
vlan 50
name testvlan50
exit

@SW2
int range fa 0/1-2
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 1,10,20,30,40,50
exit
int range fa 0/3-4
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
exit
int fa 0/3
switchport access vlan 10
exit
int fa 0/4
switchport access vlan 20
exit
@SW3
int range fa 0/1-2
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 1,10,20,30,40,50
exit
int range fa 0/3-4
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
exit
int fa 0/3
switchport access vlan 30
exit
int fa 0/4
switchport access vlan 40
exit

***********************
@SW4

vlan 10
no name SALES
name IT
exit
vlan 20
no name ACCOUNTING
exit
vlan 30
no name IT
exit
vlan 40
no name MARKETING
exit

@SW1
int vlan 1
ip address 192.168.1.11 255.255.255.0
shut
no shut
exit

@SW2
conf t
int vlan 1
ip address 192.168.1.12 255.255.255.0
shut
no shut
exit

@SW3
conf t
int vlan 1
ip address 192.168.1.13 255.255.255.0
shut
no shut
exit
@SW4
conf t
int vlan 1
ip address 172.16.50.4 255.255.255.0
shut
no shut
exit

***********************************************************************

Let us verify:

a1.PNG

a2.PNG

a3

 

a4

a5

a6.PNG

 

a7

a8.PNG

a9.PNG

a10.PNG

a11.PNG

How inter-vlan routing  works?

Honestly, I made a research on how inter-vlan routing works, and yeah I got the best on top of the research however it took almost an hour for the explanation to be elaborated. My struggle is how will I make that as simple as possible

We have the network topology below that I hope could make inter-vlan routing

1230e

 

 

Goal: PC1 on different VLAN will connect to PC2 on another VLAN

Before we go any further lemme introduce you subinterfaces

Subinterfaces are like  logical interfaces like loopback interfaces, those are interfaces which are not physically connected to the router but logically connected.

The reason why we implement logical or subinterface because in order for every vlan to be connected to another vlan, they need to be connected to the vlan gateway. In order for us to locate vlan gateway, we must either

1.) connect interfaces for every vlan from switch to router

; it may be costly because routers only have limited ports and if there are 100 vlans , it may need 100 ports  and would require additional modules

2.) The best thing to do since VLANs are also logical LANs, we can connect logical interface or subinterface to routers, and those network addresses of subinterfaces will be automatically directly connected network address.

 

Let us pretend that PC1 already knows the MAC address of R1 ( known by sending broadcast). The encapsulation that PC1 will do is

 

Source IP address (SIP) : 192.168.10.5

Destination IP add (DIP) : ip address of PC2:192.168.20.5

Source MAC (SMAC):  PC1’s mac

Destination MAC ( DMAC): R1’s

The above encapsulation will be the content of the packet that PC 1 will be sending to SW1. SW1 already learned the SMAC because it is part of the process of PC1 learning R1’s MAC address. DMAC as well is already learned by SW1 and SW1  will just forward the packet to SW2. Since the link that connects SW1 and SW2 is a trunk link it will include a tagging vlan details which is the tagging detail of PC1 (vlan 10). SW2 already learned the source and destination MAC address of the packet and will just forward the packet to R1. Since it still came from a trunk port, it will add the VLAN 10 details on the encapsulation of the packet. R1 will accept the packet and will check its routing table. R1 sees that 192.168.20.5 is just part of the network which is directly connected to it. 192.168.20.0/24 is where 192.168.20.5 belongs, so R1 will have an encapsulation of the following:

SIP:192.168.10.5

DIP:192.168.20.5

SMAC: MAC address of R1

DMAC:MAC address of PC2

R1 will forward the packet to SW2 and since R1 interface is a trunk interface, it will enclose it with the encapsulation where 192.168.20.5 belongs and it is the VLAN 20. SW2 doesn’t know the MAC address of PC2, it will replace first the destination MAC address with a broadcast adddress and since it came from trunk interface, it will be encapsulated  with VLAN 20. SW2 will send it on all sw2  vlan 20 interfaces and as well the trunk interfaces.

SW1 will get the packet from SW2 with vlan 20 details and vlan 20 will send a broadcast request to all interfaces where vlan 20 belongs and luckily, PC2 is part of vlan 20.

That’s how PC1 sends packet to PC2 and how inter-vlan works.

This is also called Router on a Stick.

Let us first verify ping connection:

1.) PC1 will ping PC2

2.)PC2 will ping PC3

3.)PC4 will ping the server

4.) PC4 will ping R2

1.)1231a

2.)1231b

3.)1231c

4.)

123g

let us try to configure R1

conf t
int fa 0/0
no ip address
! we will remove the initial ip address on that
!interface
no shut
exit

int fa 0/0.1
ip address 192.168.1.1 255.255.255.0
! moving 192.168.1.1 from parent interface to subinterface

and you will see

1231e.PNG

The highlighted message would like to make sure that the interface that we are adding subinterface ip address has a defined trunking encapsulation which is either IEEE 802.1q (trunking standard) or ISL ( cisco proprietary standard)

so let’s get back with the configuration with the sytax

! encapsulation dot1q (vlan#)

 

int fa 0/0.1
ip address 192.168.1.1 255.255.255.0
! moving 192.168.1.1 from parent interface to subinterface
encapsulation dot1q 1
!syntax:! encapsulation dot1q (vlan#)
! this is to inform the router the subinterface’s vlan and its encapsulation
exit
int fa 0/0.10
ip address 192.168.10.1 255.255.255.0
encapsulation dot1q 10
!syntax:! encapsulation dot1q (vlan#)
! this is to inform the router the subinterface’s vlan and its encapsulation
exit
int fa 0/0.20
ip address 192.168.20.1 255.255.255.0
encapsulation dot1q 20
!syntax:! encapsulation dot1q (vlan#)
! this is to inform the router the subinterface’s vlan and its encapsulation
exit

int fa 0/0.30
ip address 192.168.30.1 255.255.255.0
encapsulation dot1q 30
!syntax:! encapsulation dot1q (vlan#)
! this is to inform the router the subinterface’s vlan and its encapsulation
exit

int fa 0/0.40
ip address 192.168.40.1 255.255.255.0
encapsulation dot1q 40
!syntax:! encapsulation dot1q (vlan#)
! this is to inform the router the subinterface’s vlan and its encapsulation
exit

Let us verify:

1231f.PNG

1.) PC1 will ping PC2

 

1231g.PNG

Ha! what ‘s wrong with the ping connection? I already configured subinterfaces but ping connection is not successful.

Let us try to troubleshoot:

1231h

The first step in troubleshooting is to isolate what part of the connection is causing the ping issue:

Int fa 0/3 must be an access port, so it is ok for us to see it on access mode:

1231i.PNG

 

 

 

So we are now good with the 1st part of the isolation process, let us move to the 2nd part which is the link of SW2 and SW1:

1231k.PNG

It seems like SW2 is now all good.Since it is a switch to switch connection then we must get that interface on trunking mode

Let’s check SW1:

1231l.PNG

; interface fa 0/1 of SW3 is all good as well, let’s check the connection of SW1 and R1:

1231m

Aha! we figured out the fa 0/3 of SW1 is an access mode, we also consider switch to router interfaces as trunk interface so let us try to configure:

@SW1
conf t
int fa 0/3
switchport mode trunk
!let us remember that though fa 0/0 of R1 is also a trunk port, it doesn’t send DTP message so we must configure switch interface instead
exit

Let us first verify ping connection:

1.) PC1 will ping PC2

1231r.PNG

1231s

2.)PC2 will ping PC3

123a.PNG

 

3.)PC4 will ping the server

123b

Note: the ping is not successful because basically we did not configure yet inter-vlan routing on R2

4.) PC4 will ping R2

123f

Since we are getting sad face because the connection is not established on R2 or the inter-vlan routing is not established, let us go with the configuration:

Let us notice on our network topology, that are two existing vlan 10, first is the vlan 10 of R1 and 2nd is the vlan 10 of R2. Let us be reminded it will be ok because they are separated in different broadcast domain. Routers separates broadcast domains and so having two vlans on a network however separated by routers would be ok.

 

Additional configuration:

@SW4

conf t
int fa 0/1
switchport mode trunk
exit

conf t
int vlan 10
ip address 172.16.60.4 255.255.255.0

@R2
en
conf t
int fa 0/0
no ip address
no shut
exit

int fa 0/0.1
encapsulation dot1q 1
ip address 172.16.50.1 255.255.255.0
exit

int fa 0/0.10
encapsulation dot1q 10
ip address 172.16.60.1 255.255.255.0
exit

@R2

! on this portion, I will not discuss the routing protocols used but it is the most convenient way to establish routing on this  network

conf t
router eigrp 100
network 192.168.0.0 0.0.255.255

! advertize the network 192.168.0.0 which is not directly connected to R2
network 50.0.0.0

!advertize the network  50.0.0.0- directly connected and just one network interface so we don’t need wildcard mask as of the moment
no auto

!to disable summarization of the network address
exit

@R1
conf t
router eigrp 100
network 172.16.0.0 0.0.255.255

! advertize the network 172.16.0.0 which is not directly connected to R1
network 50.0.0.0

!!advertize the network  50.0.0.0- directly connected and just one network interface so we don’t need wildcard mask as of the moment
no auto

! to disable summarization of the network address
exit

Note: We will go further to EIGRP but as of the moment, just learn first the syntax

Alright so let’s try to check verification #3 and #4

3.)PC4 will ping the server

aaaaa.PNG

4.) PC4 will ping R2

bbbb.PNG

At last, so that’s how inter-vlan works!

HAPPY NEW YEAR mate!

*****************************End of Blog*******************************

 

 

 

3.8 Configure, verify, and troubleshoot IPv4 and IPv6 static routing

Good morning! We’ll proceed with static routing with the network topology below:

1226

The primary configurations are below:

@ BPO_MAIN_BLDG_1

enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_MAIN_BLDG_1
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr

@BPO_MAIN_BLDG_2

enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_MAIN_BLDG_2
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
@BPO_MAIN

enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_MAIN
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr

@BPO_BRANCH
enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_BRANCH
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
@BPO_BRANCH_ANNEX_1
enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_BRANCH_ANNEX_1
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
@BPO_BRANCH_ANNEX-2
enable
conf t
line console 0
password cisco
logging sync
exec-timeout 20 30
login
exit
line vty 0 15
password cisco
logging sync
exec-timeout 20 30
login
exit
hostname BPO_BRANCH_ANNEX-2
enable secret class
service password-encryption
no ip domain-lookup
banner motd “AUTHORIZED ACCESS ONLY”
do wr
***************************
@ main bldg 1

en
conf t
int se 3/0
ip add 200.0.0.1 255.255.255.252
no shut
exit
int se 2/0
ip address 200.0.0.17 255.255.255.252
no shut
exit

@main bldg 2
en
conf t
int se 2/0
ip add 200.0.0.18 255.255.255.252
shut
no shut
exit
int se 3/0
ip add 200.0.0.5 255.255.255.252
shut
no shut
exit

@ BPO_MAIN

en
conf t
int se 6/0
ip add 200.0.0.2 255.255.255.252
no shut
exit
int se 7/0
ip add 200.0.0.6 255.255.255.252
no shut
exit
int se 2/0
ip add 200.0.0.25 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.29 255.255.255.252
no shut
exit
int fa 0/0
no shut
exit

@ BPO_BRANCH

en
conf t
int se 2/0
ip add 200.0.0.26 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.30 255.255.255.252
no shut
exit
int se 6/0
ip add 200.0.0.9 255.255.255.252
no shut
exit
int se 7/0
ip add 200.0.0.13 255.255.255.252
no shut
exit
int fa 0/0
no shut
exit
@bpo annex 1

en
conf t
int se 2/0
ip add 200.0.0.10 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.21 255.255.255.252
no shut
exit
int gigabitEthernet7/0
no shut
exit

@bpo annex 2

en
conf t
int se 2/0
ip add 200.0.0.14 255.255.255.252
no shut
exit
int se 3/0
ip add 200.0.0.22 255.255.255.252
no shut
exit
int gigabitEthernet 8/0
no shut
exit

**********************************************************************

Game!

Let us verify:

 

1226b

1226c

1226e

1226f

1226g.PNG

Alright, so we’ll begin the discussion focusing on BPO_MAIN:

1226h

BPO_MAIN has next hop IP addresses:

200.0.0.1

200.0.0.5

200.0.0.26

200.0.0.30

which means  that succesful ping from BPO_MAIN to those ip addresses can be guaranteed.Let’s verify:

1226i.PNG

1226j

Let us try to get a response from remote network address, let’s say  200.0.0.10 and 200.0.0.13

1226k

So an aspiring network engineer, it is our task to provide routing or successful ping on remote network addresses. It is reasonable that we are not going to get a response because those ip addresses are not listed on the routing table of the BPO_MAIN. Let us verify:

1226l

We got possible to  200.0.0.1,200.0.0.5,200.0.0.26,200.0.0.30 because it is part of the network which is directly connected. So since we are only limited with those directly connected networks, we can add other ip address so that we can have ping response from BPO_MAIN. There are multiple ways to add it, but let us start first with static routing.

Drawbacks of Static Routing:

1.) In the event of network changes, we must manually configured static routing again

2.) It is not advisable for large networks

3.) It takes time to implement since it is manually configured.

*********************************************************************

Syntax for STATIC route

ip route (network destination) (subnet mask) (next hop ip address)

1.) Network destination is the network address of the route you want to reach

2.)Subnet mask of the network destination

3.) next hop IP address- it is the ip address of the neighbor to which you need to pass the packet to  reach the network destination.

1226m.png

Game, let us start configuring static route.

Technique:It may be going to be hard to know the remote network addresses of other routers, because it may require us subnetting techniques, but we can easily know the remote network addresses by making a telnet session to the branch router and make a show ip route to that branch router.

1226n

Configuration:

Let us try to reach BPO_MAIN_BLDG_1 first:
en
conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.1
ip route 200.0.0.16 255.255.255.252 200.0.0.1
exit

Let us try to get a ping to 200.0.0.17 and 200.0.0.1

1226o

Verify:

1226p

There you go! We’ve seen that the network 200.0.0.16 was learned via static configuration by the help of next hop ip address: 200.0.0.1

Let us try to reach BPO_MAIN_BLDG 2
en
conf t
ip route 200.0.0.4 255.255.255.252 200.0.0.5
ip route 200.0.0.16 255.255.255.252 200.0.0.5
exit

Verify:

12261.PNG

Check ping:

ping 200.0.0.18

ping 200.0.0.5

1226q.PNG

Alright, so BPO_MAIN  is now reaching the left side of the network . I’ll get back to you once I finished the entire configuration for all the routers.

Yup, I took my breakfast and finally done with the static configuration:

Static Route
@ BPO MAIN

en
conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.1
ip route 200.0.0.16 255.255.255.252 200.0.0.1
exit
en
conf t
ip route 200.0.0.4 255.255.255.252 200.0.0.5
ip route 200.0.0.16 255.255.255.252 200.0.0.5
exit

en
conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.26
ip route 200.0.0.8 255.255.255.252 200.0.0.30
exit
ip route 200.0.0.12 255.255.255.252 200.0.0.26
ip route 200.0.0.12 255.255.255.252 200.0.0.30
exit
conf t
ip route 200.0.0.24 255.255.255.252 200.0.0.26
ip route 200.0.0.28 255.255.255.252 200.0.0.30
exit
conf t
ip route 200.0.0.24 255.255.255.252 200.0.0.30
ip route 200.0.0.28 255.255.255.252 200.0.0.26
exit

conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.26
ip route 200.0.0.20 255.255.255.252 200.0.0.26
exit
conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.30
ip route 200.0.0.20 255.255.255.252 200.0.0.30
exit

@BPO MAIN BLDG 1

conf t
ip route 200.0.0.4 255.255.255.252 200.0.0.18
ip route 200.0.0.16 255.255.255.252 200.0.0.18
exit
conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.2
ip route 200.0.0.14 255.255.255.252 200.0.0.2
ip route 200.0.0.24 255.255.255.252 200.0.0.2
ip route 200.0.0.28 255.255.255.252 200.0.0.2
exit
conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.2
ip route 200.0.0.12 255.255.255.252 200.0.0.2
ip route 200.0.0.24 255.255.255.252 200.0.0.2
ip route 200.0.0.28 255.255.255.252 200.0.0.2
exit
conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.2
ip route 200.0.0.20 255.255.255.252 200.0.0.2
exit
conf t
ip route 200.0.0.12 255.255.255.252 200.0.0.2
ip route 200.0.0.20 255.255.255.252 200.0.0.2
exit
*************************************

@ BPO MAIN BLDG 2

conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.17
ip route 200.0.0.16 255.255.255.252 200.0.0.7
exit

conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.6
ip route 200.0.0.4 255.255.255.252 200.0.0.6
ip route 200.0.0.24 255.255.255.252 200.0.0.6
ip route 200.0.0.28 255.255.255.252 200.0.0.6
exit

conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.6
ip route 200.0.0.12 255.255.255.252 200.0.0.6
ip route 200.0.0.24 255.255.255.252 200.0.0.6
ip route 200.0.0.28 255.255.255.252 200.0.0.6
exit

conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.6
ip route 200.0.0.20 255.255.255.252 200.0.0.6
exit

conf t
ip route 200.0.0.12 255.255.255.252 200.0.0.6
ip route 200.0.0.20 255.255.255.252 200.0.0.6
exit

******************************************

@ BPO branch

conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.10
ip route 200.0.0.20 255.255.255.252 200.0.0.10
exit

conf t
ip route 200.0.0.12 255.255.255.252 200.0.0.14
ip route 200.0.0.20 255.255.255.252 200.0.0.14
exit

conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.25
ip route 200.0.0.4 255.255.255.252 200.0.0.25
ip route 200.0.0.24 255.255.255.252 200.0.0.25
ip route 200.0.0.28 255.255.255.252 200.0.0.25
ip route 200.0.0.0 255.255.255.252 200.0.0.29
ip route 200.0.0.4255.255.255.252 200.0.0.29
ip route 200.0.0.24 255.255.255.252 200.0.0.29
ip route 200.0.0.28 255.255.255.252 200.0.0.29
exit

conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.25
ip route 200.0.0.16 255.255.255.252 200.0.0.25
ip route 200.0.0.0 255.255.255.252 200.0.0.29
ip route 200.0.0.16 255.255.255.252 200.0.0.29
exit
conf t
ip route 200.0.0.4 255.255.255.252 200.0.0.25
ip route 200.0.0.16 255.255.255.252 200.0.0.25
ip route 200.0.0.4 255.255.255.252 200.0.0.29
ip route 200.0.0.16 255.255.255.252 200.0.0.29
exit

*********************
@ ANNEX 1

conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.9
ip route 200.0.0.12 255.255.255.252 200.0.0.9
ip route 200.0.0.24 255.255.255.252 200.0.0.9
ip route 200.0.0.28 255.255.255.252 200.0.0.9
exit

conf t
ip route 200.0.0.12 255.255.255.252 200.0.0.14
ip route 200.0.0.20 255.255.255.252 200.0.0.14
exit

conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.9
ip route 200.0.0.4 255.255.255.252 200.0.0.9
ip route 200.0.0.24 255.255.255.252 200.0.0.9
ip route 200.0.0.28 255.255.255.252 200.0.0.9
exit

conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.9
ip route 200.0.0.16 255.255.255.252 200.0.0.9
exit
conf t
ip route 200.0.0.4 255.255.255.252 200.0.0.9
ip route 200.0.0.16 255.255.255.252 200.0.0.9
exit

@ Annex 2

conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.21
ip route 200.0.0.20 255.255.255.252 200.0.0.21
exit

conf t
ip route 200.0.0.8 255.255.255.252 200.0.0.13
ip route 200.0.0.12 255.255.255.252 200.0.0.13
ip route 200.0.0.24 255.255.255.252 200.0.0.13
ip route 200.0.0.28 255.255.255.252 200.0.0.13
exit

conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.13
ip route 200.0.0.4 255.255.255.252 200.0.0.13
ip route 200.0.0.24 255.255.255.252 200.0.0.13
ip route 200.0.0.28 255.255.255.252 200.0.0.13
exit
conf t
ip route 200.0.0.0 255.255.255.252 200.0.0.13
ip route 200.0.0.16 255.255.255.252 200.0.0.13
exit
conf t
ip route 200.0.0.4 255.255.255.252 200.0.0.13
ip route 200.0.0.16 255.255.255.252 200.0.0.13
exit

PING TEST @ BPO MAIN BLDG 1

1226r.PNG

PING TEST @  BPO MAIN

1226s.PNG

At last we are getting succesful ping response whether we are on the side or at the middle of the topology.

Let’s check  and analyze the routing table of each  routers:

1226t

We are getting successful route from upper left router to either middle right, top or bottom routers because we configured it manually. We can verify that on the picture above. Let’s say that network address 200.0.0.8, though it is not directly connected to BPO MAIN BLDG 1 but it was learned manually by the help of 200.0.0.2. Also, let us check the highlighted [1/0] which represents the administrative distance and the metric which serves as the reference of what is the best path.

Other routing table shows:

1226ta

1226tb.PNG

1226tc

1226td.PNG

1226te

Alright, I’m challenging everyone to interpret how each routers learned the route to the network destination. It will be just easy to explain here but will take time because there are 6 routers. But seriously, it is just easy interpreting the routing table.

 

************************END OF BLOG**********************************